Version 1.3.13 released

Submitted by Matthew Smith on Sat, 2013-01-19 00:44

I've just put out a new version of QTM: version 1.3.13. The main new feature this time is that it's Qt 5 ready. Qt 5 compiles and runs fine on Linux (X11) and can be made to work on Windows (the tool-chain has changed on Windows so it's a bit more complicated). Sadly, on the Mac, some functionality QTM relies on in Qt 4 has not been updated for Qt 5 yet, so you'll still need Qt 4 on the Mac. However, the downloads for Windows still use Qt 4 as Qt 5 is a bit rough around the edges. There is no functionality in QTM that requires Qt 5.

Also, there are a couple of bug fixes. The main fix is that, when you post an entry and it fails (because you had the wrong password, for example), it no longer declares the entry posted -- which means when you correct the problem, it will now be able to post it properly. Previously, it would have tried to post an edit for an entry the blog system didn't have.

Downloads are available for Windows and Mac from the box on the right, or you can download the source code and compile it yourself. If you've subscribed to my archives on Ubuntu, OpenSUSE or Fedora, you need just update your software and the new version will appear. If you haven't, instructions for using the download repositories can be found here.